How to rotoscope

Rotoscoping is an animation technique in which you draw, paint, or add other visual effects in a layer over live-action film or video, one frame at a time. The technique was invented by Max Fleischer in 1914, when he projected motion film images onto a frosted glass panel. He traced the images on the glass, one frame at a time, creating realistic animation. His original equipment was called the rotoscope (Figure 1). Modern rotoscoping has been replaced by special computers and software such as After Effects, but the name “rotoscoping” remains.

If you’ve been to the movies or watch television, you’ve probably seen the results of rotoscoping. For example, an object or character appears in color when everything else is black and white (Figure 2). Anytime it looks like someone has drawn or painted over the movie, frame-by-frame, you are probably looking at the result of rotoscoping.

Figure 1 Fleischer’s original rotoscope.

Figure 2 Example of rotoscoping, music video screenshots from A-ha’s “Take On Me.”
Rotoscoping in After Effects

These days, rotoscoping refers to the technique of creating a matte for a moving element on one layer so that it can be composited over another background layer (Figure 3). As you can imagine, creating this matte in every frame of a movie is a laborious process, but necessary if you don’t have a good key or haven’t shot footage in which the foreground is easily separated from the background. Rotoscoping can be easily accomplished using the Roto Brush and Refine Edge tools in After Effects, making this process a lot more efficient by selecting and masking each frame in less time and with greater accuracy.

Figure 3 Using rotoscoping effects on nature footage to reimagine marine life in another environment

You should complete the Premiere Pro guide titled How to apply and adjust keying effects before doing the tasks in this After Effects guide. Keying and rotoscoping are not the same process, but understanding keying will help you understand what you hope to accomplish by rotoscoping.

It's easy to confuse rotoscoping with keying effects. With keying, you have shot your footage with a foreground and background that you can easily separate and replace. For example, you may have shot your subjects in front of a blue or green screen. Rotoscoping allows you to work with your existing footage that was shot in its natural environment.

To complete the tasks in this guide, you will need to import a short video clip with some motion, as well as a background image. The best sort of video clip has at least one moving object in the foreground that you would like to isolate from the background scene. Once rotoscoping of video frames is completed, use the Refine Edge tool to clean up loose ends, including small areas of the foreground that are difficult to mask. Work through these tasks using your own assets or download the files used in this tutorial here. This guide is adapted from the Adobe Help tutorial Rotoscope nature footage.
To add the foreground and background layers:

1. Start After Effects.

2. In the main menu, select Composition > New Composition.

   The Composition Settings dialog box appears (Figure 4).

3. Name the composition Rotoscoping, select an appropriate video preset, and click OK.

4. In the main menu, select Window > Workspace > Motion Tracking.

5. Choose File > Import > File. Browse to locate your motion video clip and background image, select them, and click Open.

   The files appear in the Project panel.

6. Drag the video clip to the Rotoscoping composition in the Timeline panel.

   This copy of the clip will be the foreground.

7. Drag the background image file to the Rotoscoping composition in the Timeline panel, and place it on the track below the video clip.

   You may need to adjust the length of the image in the Timeline to match the length of the video clip (Figure 5).

Creating a matte by rotoscoping

You need to create a matte (or more specifically, a series of mattes in each frame) so you can isolate and apply special effects to a portion of the image without affecting its surroundings. You can do this by using the Pen tool to carefully select objects in every frame. But it’s a lot faster to use the Roto Brush tool.
To create a matte by rotoscoping:

1. Double-click the video clip in the top layer of the Rotoscopy composition Timeline.
   
   The video opens in the Layer panel (Figure 6).

2. Click the First Frame button in the Preview panel (Figure 7) to move the current time indicator (CTI) to the first frame of the selected video clip.
   
   You need to rotoscope every frame in the video, so you’ll start on frame 1.

3. Choose View > Resolution > Full.
   
   Work with the Roto Brush in full resolution for more accurate selection.

4. Select the Roto Brush tool in the Tools panel (Figure 8).
   
   With the Roto Brush tool selected, the pointer changes to a green circle with a plus sign.
5. In the Layer panel, drag over an object you want to isolate in the foreground (Figure 9).

The Roto Brush paints in green, and After Effects selects an area. It’s trying to guess which part of the frame you want selected (Figure 10). The alpha boundary for the matte is defined by a bright colored line (pink by default).

**Note:** To change the size of the brush you can hold down **Ctrl** (Windows) or **Command** (Mac OS) and drag the pointer.

**Note:** If using the demo assets, you may see a warning message about **Frame Rate Mismatch**. If this is so, select **Composition > Composition Settings** and reset **Frame Rate** to match the suggested settings. Rotoscoping requires a specific frame rate to work properly.

6. If needed, drag over another part of the object to add to the selection.

More of the object is selected. Sooner or later, you’ll end up selecting parts of the image that belong in the background.

You can remove from the selection by holding down **Alt** (Windows) or **Option** (Mac OS) as you draw with the Roto Brush. When you remove from the selection, the Roto Brush changes to a red circle with a minus sign and paints in red (Figure 11).

**Note:** To paint small regions, you can click the Roto Brush instead of dragging it.

7. Continue to draw with the Roto Brush, adding and subtracting from the selection until you’ve isolated the objects from the rest of the image.
Refining a Roto Brush selection

Before you move to the next frame and continue rotoscoping, you can further refine the edge selection by using the options in the Effect Controls panel.

To refine a Roto Brush selection:

1. In the Layer panel, click the Toggle Alpha Boundary button (Figure 12).

   Turning off Alpha Boundary view mode helps you see the boundary of the matte. Based on what you see, you may need to add to or remove from the selection.

2. In the Layer panel, click the Toggle Alpha button.

   This view shows a cutout of the selection area. By removing the video, you can see the edges of the selection better (Figure 13).

3. In the Layer panel, click the Toggle Alpha Overlay button.

   Now you see an overlay of everything inside and outside the selection area, but the area outside the selection is tinted. This is the Alpha Overlay view mode.

   Toggling between views help you see the result of your choices as you refine the selection.

Figure 12 Layer panel, Alpha Boundary view turned off

Figure 13 Viewing the matte
4. In the **Effect Controls** panel, expand the **Roto Brush** effect properties and expand the **Matte** options (Figure 14).

   Confirm **Fine-Tune Roto Brush Matte** is set to **On**.

5. Experiment with the **Roto Brush Matte** settings to refine the edges of your matte.

   You can get good results by increasing the **Feather** value, reducing **Shift Edge** to a negative amount, and adjusting the **Reduce Chatter** percentage to help smooth the edges.

   **Note**: You can click **Reset** in the **Effect Controls** panel to return to the default **Roto Brush** settings.

**Modifying the matte in other frames**

You’ve defined the mask for the first frame, now you need to step through the rest of the frames in the sequence to make sure the mask is precise. After Effects uses a combination of techniques to automatically calculate the edges of the object that is defined in the first frame, and applies it to the following frames as best as possible. For best results, step through the frames and make manual corrections when necessary.

**To modify the matte in other frames:**

1. Click and drag the Roto Brush span (the dark gray bar) to increase its length, so it takes up the full length of the footage (Figure 15).
2. In the Preview panel, click the Next Frame button.

As you move forward in the clip, the objects move beyond the outline of the matte you created for frame 1. After Effects attempts to adjust the selection automatically.

3. If you notice any areas where the edge of the mask needs to be refined, use the Roto Brush tool to make the corrections, adding foreground or subtracting background as necessary (Figure 16). Follow this same step for all the frames in your footage.

Note: Rotoscoping is a time-consuming process, but the Roto Brush tool is a huge time saver compared to drawing selections in each frame by using the Pen tool.

![Selection needs adjustment](image1)

**Figure 16** Selection needing adjustment (left) and the final selection result (right)

---

**Cleaning up loose ends with the Refine Edge tool**

Once you’ve completed your rotobrush selections in each frame, you may still find that you’re left with less than perfect boundaries between your selection and the background. For example, whisps of hair, where the thin spaces between objects can be difficult to isolate. You can use the Refine Edge tool to fine tune your selections. Before using the Refine Edge tool, complete your Roto Brush tool selection for all frames. Once you’ve completed your selections, you can then go back and refine those selections by using the Refine Edge tool.

**To use the Refine Edge tool:**

1. Click and hold on the Roto Brush tool in the Tools panel to reveal the Refine Edge tool (Figure 17).
2. Select the *Refine Edge Tool*.

   **Note:** You will drag along the edge of your mask to add or remove elements from the masked area. You want the Refine Edge tool size to be large enough that it extends into the areas you want to add or remove, but not so large that it picks up too many colors. The process is trial-and-error.

![Figure 17 Tools panel](image2)
3. **Control+drag** (Windows) or **Command+drag** (Mac OS) to size the Refine Edge tool.

4. Using the Refine Edge tool, drag along the edge you want to refine (Figure 18).

   **Note:** When you release the mouse button, you see what’s referred to as an x-ray view.

![Figure 18 Selecting the edge to refine (left) and Refine Edge selection x-ray view (right)](image)

5. Click the Toggle Refine Edge X-Ray View button (Figure 19).

   The Refine Edge tool creates areas of semi-transparency to smooth the edges of your matte (Figure 20).

![Figure 19 Layer panel detail](image)

![Figure 20 Refined Edge](image)
Applying effects after rotoscoping

When you're finished rotoscoping the entire clip, you can apply video effects to it. Your effects will apply only to the selected objects; everything outside the selection is transparent. Since you've placed an image behind the video clip, you can create the illusion of transporting the selected objects into the new scene.

To apply effects after rotoscoping:

1. Click the Composition panel to see the effect of the rotoscoping process (Figure 21).

2. If needed, select the bounding box handles to resize and rotate the video clip so it fits the scene.

3. Choose Window > Workspace > Effects.

4. In the Effects & Presets panel, expand the Color Correction bin.

5. Drag the Curves effect and drop it onto the video in the Composition panel.

   The effect applies only to the objects you selected by rotoscoping. The rest of the clip is transparent and the background image shows through.

   **Note:** You can adjust the Curves effect properties in the Effect Controls panel to increase or decrease the color values (Figure 22).

6. To make a convincing composite, try adding other color correction layers like Hue/Saturation, Photo Filter, and Brightness & Contrast effects. Experiment as needed.

7. Move the CTI to the beginning of the clip and click the Play button in the Preview window to preview the effects in motion.

   **Note:** After viewing the result of rotoscoping, you can go back to specific frames and use the Roto Brush and Refine Edge tools to change or refine your matte as needed.

---

**For more information**

Get instant access to free courses, workshops, & teaching materials and connect with the creative education community on the Adobe Education Exchange: https://edex.adobe.com/.