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How to animate text
After Effects includes hundreds of animation, text and effect options, as well as a complicated and 
potentially overwhelming set of tools. To cover these all in depth would take much more than a 
single guide. This document provides an easy introduction to the many powerful features available in 
the application. To do this, you will review options for animating text (Figure 1), use presets, and work 
with paint tools.  

Some prior experience will be helpful; consider completing the following Premiere Pro and After 
Effects guides before tackling the tasks in this document:

• Overview of Adobe After Effects: A brief introduction to the workspace, which is similar in form and 
function to Adobe Premiere Pro.

• How to use the Motion effect and How to apply and adjust video effects: These Premiere Pro guides 
cover effect properties and keyframes. Both tools are used extensively in After Effects.

• How to work with alpha channel transparencies: This Premiere Pro guide introduces compositing—
the process of creating a compound image by superimposing one or more clips on another clip.

Work through this guide using your own assets or download the files used in this tutorial here.

Figure 1 Using After Effects to animate text and add video effects

https://edex.adobe.com/resource/1d3534
https://edex.adobe.com/resource/a64-00
https://edex.adobe.com/resource/-b6167
https://adobe.ly/2jVQC3A
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Opening an Adobe Premiere Pro project in After Effects

You can open and work with Adobe Premiere Pro projects in After Effects.

To open an Adobe Premiere Pro project in After Effects: 

1. Start After Effects.

The workspace opens, as well as the Start screen (Figure 2).

2. Close the Start screen.

3. Select File > Import > Adobe Premiere Pro Project, 
navigate to and select a fully rendered Adobe Pre-
miere Pro project with several layered clips and 
tracks, and click Open.

The Premiere Pro Importer dialog box appears 
(Figure 3).

4. Accept the default settings—All Sequences and 
Import Audio—and click OK.

Figure 2 The Start screen

Figure 3 Premiere Pro Importer dialog box
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5. Select Window > Workspace > Standard to view the 
standard workspace layout.

The Adobe Premiere Pro project assets appear in the 
After Effects Project panel (Figure 4).

Note: Adobe Premiere Pro sequences are called 
compositions in After Effects.

6. In the Project panel, click the Project Flowchart View 
button.

The Flowchart panel appears in the top-center of the 
workspace.

7. In the Flowchart panel menu (Figure 5), select  
Left To Right.

Your flowchart should look something like the 
example. You might need to click the small plus sign 
(+) at the left end of the composition box to display all 
the assets.

Note: The Flowchart panel shows you only the 
existing relationships. You cannot use it to change 
relationships between project elements.

Figure 5 Flowchart panel

Figure 4 Project panel

Project 
Flowchart

Panel menuPlus sign to display layers
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8. In the Project panel, double-click a composition.

The composition appears in the Timeline (Figure 6). Make note of the following:

• Instead of tracks, you work with layers in After Effects.

• Each numbered layer contains an asset or effect from the original Premiere Pro project.

• Edits, effects, motion keyframes, transparencies, nested sequences, crops, and clip speed changes built in 
the Premiere Pro project are all maintained when imported into After Effects.

• Premiere Pro transitions show up with solid black squares in front of their names in the Timeline panel. 
After Effects cannot play Premiere Pro transitions.

9. Drag the CTI through the Timeline to view the com-
position in the Composition panel (Figure 7).

10. In the Timeline panel, double-click a video clip.

The clip appears in the Layer panel (Figure 8). You 
may need to move the CTI in the Timeline to see the 
selected clip in the Layer panel.

Note: Generally, the Layer panel shows a layer before 
any effects are applied to the asset in the layer. For 
example, the Layer panel does not show the result of 
modifying a layer’s Rotation properties. To see a layer 
in context with other layers and with the results of 
effects applied to it, use the Composition panel.

You can perform many tasks in either the 
Composition panel or the Layer panel. However, 
some tasks—such as tracking motion and using the 
paint tools—must be performed in the Layer panel.

Figure 7 Composition panel

Figure 6 Timeline panel

Figure 8 Layer panel



5How to animate text  After Effects Guide© 2017 Adobe Systems Incorporated. 
This document requires Adobe After Effects CC 2017. Technical instructions may differ depending on your version.

11. In the Timeline panel, click the triangle to the left of a clip that has some Premiere Pro effects applied to it, and 
then click any other triangles that appear below it.

All effects applied to the clip appear below it (Figure 9). Make note of the following:

• Premiere Pro effects, such as Bevel Edges, display the same options in After Effects as in Premiere Pro.

• Transform is the After Effects version of the Premiere Pro Motion effect.

• Keyframes look the same in After Effects as in Premiere Pro and most have the same properties.

12. Select File > Close Project.

13. When After Effects asks whether to save the project, click Don’t Save.

Animating text

Adding text to an After Effects composition and then animating it is a simple matter. You can animate text just as you 
would in Adobe Premiere Pro, by applying Transform properties (equivalent to using the Adobe Premiere Pro Motion 
or Transform effects), or you can go far beyond that basic level of animation. In After Effects, you can apply animations 
on a per-character or per-word basis, have characters move along a curved path, and have characters change to other 
characters. Animations can include changing colors, 3D motion, blurring, and other effects.

To create text and move it in 3D space: 

1. Start After Effects

2. In the main menu, select Composition > New Com-
position.

The Composition Settings dialog box appears  
(Figure 10).

3. Name the composition Text Motion, and select an ap-
propriate video preset.

4. Click the Background Color swatch to open the Color 
Picker. Give your composition a color other than the 
default black.

5. Accept the other default settings and click OK.

Figure 10 Composition Settings dialog box

Figure 9 Timeline panel, clip effects
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6. Click Text in the workspace bar at the top of the 
screen. You may have to click the Overflow menu to 
reveal this option.

The workspace rearranges and the  Character and 
Paragraph panels appear on the right side.

7. In the Tools panel, click the Horizontal Type tool 
(Figure 11).

8. Click in the Composition panel and type some text.

9. In the Tools panel, click the Selection tool.

Make sure the text is selected. In the Character panel, 
change the font choice, size, color, and typeface style 
(bold, italic, all caps, etc.) and add a stroke (Figure 12).

Note: The two overlapping squares in the upper-right 
corner of the Character panel specify the fill and 
stroke colors and whether they’re activated. (Click the 
small box with the red diagonal line to turn off the 
display of whichever color box is in front.) The stroke 
menu lets you select whether the stroke is over or 
under the fill.

10. Use the Selection tool to position the text in the  
Composition panel.

11. In the Timeline panel, display the text layer’s effects by clicking the disclosure triangle next to the layer name and 
then clicking the triangles next to Transform and Text, as shown in (Figure 13).

Note: As mentioned earlier, the After Effects Transform effect has, in addition to Opacity, the keyframeable 
options found in the Premiere Pro Motion effect.

Figure 11 Type tool in the Tools panel

Horizontal type toolSelection tool

Figure 12 Character panel

Stroke 
Color

Fill 
Color

Stroke 
menu

Figure 13 Timeline panel, Transform options

Disclosure triangles

Time-Vary stopwatch button
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12. Set keyframes for some of the Transform options as 
follows:

• Move the CTI to the beginning of the compo-
sition.

• Click the Time-Vary stopwatch button (equiv-
alent to the Toggle Animation button in 
Premiere Pro) to switch on keyframes for any 
option.

• Select an option value (a keyframe appears in 
the time ruler). Do this for more than one 
option.

• Move the CTI into the timeline a few seconds.

• Change the option parameters to add more 
keyframes.

13. Drag the CTI to the beginning of the timeline then 
click the Play button in the Preview panel (or drag the 
CTI in the Timeline panel) to see your work.

14. Position the CTI so the text is visible in the  
Composition panel.

15. In the Timeline panel, click the 3D Layer button (the 
empty box below the 3D cube icon) (Figure 14).

A number of 3D options appear in the Timeline panel: 
Orientation, X/Y/Z Rotation, and Material Options 
(Figure 15).

16. In the Timeline panel, set new properties for the X, Y, 
and Z Rotation properties.

In the Composition panel, the text rotates in 3D 
(Figure 16).

Figure 15 Timeline panel with 3D options selected

Figure 14 3D Layer button in Compostion panel

3D Layer button

Figure 16 3D axis layer control
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17. In the Tools panel, select the Rotation tool.

The Set Orientation/Rotation For 3D Layers menu 
appears to the right of the Tools panel (Figure 17).

18. In the Set Orientation/Rotation For 3D Layers menu, 
select Orientation or Rotation.

19. In the Composition panel, drag the Rotation tool on 
the text.

As you mouse over the 3D axis layer control, the 
cursor displays the effected axis and the Rotation tool 
icons (Figure 18). 

Make note of the changing values in the Timeline 
panel. Any changes you make are keyframeable.

To place and move text on a curve: 

1. Select Composition > New Composition, and name 
the composition Text on a Curve. Select an appropri-
ate video preset, accept the defaults, and click OK.

2. In the Tools panel, select the Horizontal Type tool. 
Click anywhere in the Composition panel screen, and 
type some text.

A text layer appears in the Timeline panel.

3. Display the text layer’s effects by clicking the triangle 
next to its name. Further expand the Text and Path 
Options.

4. In the Tools panel, click the Pen tool (to the left of the 
Horizontal Type tool).

5. Create a curved path (Figure 19).

Make sure the text is still selected before you draw 
the line; otherwise, you will create a shape with a fill.

A Masks option is added to the text layer in the 
Timeline panel.

6. In the Timeline panel, select Mask 1 from the Path 
menu (Figure 20).

Figure 17 Set Orientation/Rotation For 3D Layers menu

Figure 20 Timeline panel, Text and Path Options

Figure 18 Axis layer and Rotation tool icons

Figure 19 Composition panel, showing curve
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The text drops onto the path in the Composition 
panel (Figure 21). Additional path options appear in 
the Timeline panel.

7. Drag the CTI to the beginning of the Timeline.

8. Click the First Margin Time-Vary stopwatch to turn on 
keyframes and set a keyframe at the beginning of the 
Timeline.

9. Drag the First Margin value to the left. As you drag 
left, the value becomes a negative number and the 
text moves left along the path in the Composition 
panel (Figure 22). Adjust this value so the text begins 
off the path to the left in the Composition panel 
(Figure 23).

10. Drag the CTI further down the Timeline and add 
another keyframe for the First Margin effect. To add  
a keyframe, click the Add Or Remove Keyframe At 
Current Time button.

11. With the CTI on the second keyframe, drag the  
First Margin value to the right to move the text to  
the right. Adjust this value so the text ends off the  
path to the right in the Composition panel  
(Figure 24).

12. Move the CTI to the beginning of the Timeline and 
play the composition.

The text travels along the path from left to right.

Figure 21 Text on the curve path

Figure 23 First Margin position at the first keyframe

Figure 22 Path Options

Time-Vary stopwatch buttonAdd Or Remove 
Keyframe At  
Current Time button

Figure 24 First Margin position at the second keyframe
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To animate text: 

1. Select Composition > New Composition. In the 
Composition Settings dialog box, name the composi-
tion Text Animation, select an appropriate video 
preset, accept the other defaults, and click OK.

2. In the Tools panel, select the Horizontal Type tool. 
Click anywhere in the Composition panel screen, and 
type some text.

A text layer appears in the Timeline panel.

3. Display the text layer’s effects by clicking the triangle 
next to its name.

4. In the Animate menu, select Position (Figure 25).

In the Timeline panel, the Text options expand 
further and the Animator 1 options are added  
(Figure 26).

5. Expand the Animator 1 options, expand the Range 
Selector 1 options, and set Position to 0, 800.

The text drops below the Composition panel screen.

Note: Depending on the presets you selected for the 
composition, you may need to use a different position 
value to move the text below the Composition panel 
screen.

6. In the Magnification Ratio menu of the Composition 
panel, select 25% (Figure 27).

The text bounding box and handles appear at the 
bottom of the Composition panel screen.

Figure 26 Timeline panel, Animator 1 options

Figure 25 Timeline panel, Text Animate options

Animate menu

Figure 27 Compostion panel

Magnification Ratio menu
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7. In the Timeline panel, set keyframes for the Start 
option: 0% at the beginning and 100% a few seconds 
into the composition (Figure 28).

The text appears on-screen again.

8. Play this composition.

The text jumps up from beneath the screen, one letter 
at a time.

9. In the Animator 1 Add menu, select Property > Skew.

Skew and Skew Axis options appear in the Timeline 
panel.

10. Set Skew to 45 and play the composition.

The letters appear on-screen, skewed to the right, and 
then quickly straighten up as they arrive in place.

11. In the Animator 1 Add menu, select Property > Opac-
ity. The Opacity option appears in the Timeline panel.

12. Set Opacity to 0% and play the composition.

The letters start animating at 0% opacity and quickly 
increase to 100% as they arrive in place.

13. In the Animator 1 Add menu, select Selector > 
Wiggly.

The Wiggly Selector 1 option appears in the Timeline 
panel.

14. Display the Wiggly Selector 1 options.

You can accept the defaults or change the settings. The options are plentiful.

15. Play the composition.

The text has a wild animation (Figure 29).

To apply per-character animation: 

1. Select Composition > New Composition.

2. In the Composition Settings dialog box, name the composition Character Animation, select an appropriate video 
preset, accept the other defaults, and click OK.

3. In the Tools panel, select the Horizontal Type tool. Click anywhere in the Composition panel screen, and type 
enough text to fill the width of the screen.

A text layer appears in the Timeline panel.

Figure 28 Range Selector 1 Start keyframes

Add menu

Figure 29 Text with Wiggly option applied
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4. Expand the text layer’s options. In the Text Animate 
menu of the Timeline panel, select Scale.

An Animator 1 option is added, with Range Selector 1 
and Scale displayed (Figure 30).

5. Set both Scale values to 300%.

6. In the Animator 1 Add menu, select Property > 
Tracking, and set Tracking Amount to 30.

7. Expand the Range Selector 1 options and set the 
following (Figure 31):

• In the Advanced options Units menu, select 
Index.

• Set Start to 0.

• Set End to 3 (to animate 3 characters at a 
time).

• Click the Offset option Time-Vary stopwatch 
button and set two keyframes:

• At the beginning of the composition: –3

• A few seconds into the composition, with 
Offset set to the number of characters 
and spaces in your text phrase

Note: With a starting Offset value of –3, the animation 
starts three characters before the first character. If you 
had chosen a value of 0, the first three characters 
would initially display at 300% of their normal size. By 
selecting –3, the 300% value is applied to three virtual 
characters at the outset. The actual first three 
characters of your text string are treated as the 4th 
through 6th characters of this animation, so they 
initially display at their regular size.

8. In the Timeline panel, click the text layer name 
(whatever you typed in the Composition panel) to 
select that layer.

Note: This ensures that the next Animate menu 
selection creates a separate Animator option.

9. In the Text Animate menu, select Fill Color > RGB.

An Animator 2 option is added, with Range Selector 
1 and Fill Color displayed (Figure 32).

Note: The Fill Color default color is Red. You can 
change that and use keyframes to animate color 
changes over time. In this case, let the Wiggly 
function change the intensity of a single color.

Figure 30 Timeline panel, Animator 1 options

Figure 31 Timeline panel, Range Selector options

Offset option Time-Vary stopwatch button

Figure 32 Timeline panel, Animator 2 options
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10. In the Animator 2 Add menu, select Selector > 
Wiggly.

11. Play the composition and note how the red color 
shifts as the characters animate (Figure 33).

Using text animation presets 

Many other types of text animation are available in After Effects. You can animate text outlines and text interiors with 
scribbles, wiggles, multiple colors, and such. Letters can bounce, move through 3D space, twist, bend, curl, flip, invert, 
change colors and opacities, and even change randomly to different characters or to preselected words. Test the many 
parameters available within the Add and Animate menus built into any text layer in the Timeline panel and refer to 
After Effects Help for more information.

One quick way to get an idea of the possibilities is to use a preset. After Effects has hundreds of text animation presets, 
including 3D text animation.

To use a text animation preset: 

1. Select Composition > New Composition. In the 
Composition Settings dialog box, name the composi-
tion Text Animation Presets, select an appropriate 
video preset, accept the other defaults, and click OK.

2. Select Window > Workspace > Effects.

3. In the Tools panel, select the Horizontal Type tool, 
click anywhere in the Composition panel screen, and 
type at least two words.

4. In the Effects & Presets panel, expand Animation 
Presets, and open the Text bin.

There are more than a dozen text-animation preset 
bins (Figure 34).

Figure 34 Effects & Presets panel Text presets

Figure 33 Per-character animation
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5. In the Animate In bin, drag and drop Center Spiral to 
the text in the Composition panel screen.

Two option sets are added to the text layer in the 
Timeline panel. These are Animator layers that have 
been renamed as a convenience. Spiral applies 
rotation keyframes and Fade In adds opacity 
keyframes.

Expand the text layer’s options to see these options 
(Figure 35).

6. Press the spacebar to play the animation.

Mid-animation, the text should look something like 
the example (Figure 36).

7. Select Edit > Undo to undo the preset.

Note: You may need to select Edit > Undo more than 
one time.

8. In the Effects & Presets panel, click the 3D Text bin 
(the first Text Animation Preset bin) to expand it, and 
drag 3D Rain Down Words & Colors to the text in the 
Composition panel screen.

Three option sets are added to the text layer in the 
Timeline ruler: More Options, Animator 1, and 
Animator 2.

9. Play that animation.

The text flips onto the screen, one word at a time.

10. In the Timeline panel, display the Animator 1 options, 
display the Range Selector 1 options, and display the 
Advanced options (Figure 37).

11. In the Advanced options Based On menu, select 
Characters.

Figure 35 Timeline panel, Spiral and Fade In options

Figure 36 Center Spiral text animation preset

Figure 37 Timeline panel, Spiral and Fade In options
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12. Play the animation.

This time the text flies on-screen one character at a 
time (Figure 38).

Trying out text animation presets is guaranteed to 
keep you busy for a long time. When you add a 
preset, take a look at the Timeline panel and note that 
each preset adds options and keyframes. You can 
customize presets by changing the option values and 
keyframe locations.

Using paint tools

After Effects has a set of Adobe Photoshop-style paint tools. You can use them to create some wild, animated art or to 
add animation or images to video in rotoscope style.

Working with paint tools is slightly different from working with text tools. When you create text, you automatically 
create a new layer in the Timeline panel and you work directly in the Composition panel. With paint tools, you create a 
composition layer and work on that layer in the Layer panel.

To use the paint tools: 

1. In the main menu, select Composition > New Com-
position.

2. In the Composition Settings dialog box, name the 
composition Paint Tools, select an appropriate video 
preset, accept the other defaults, and click OK.

3. In the main menu, select Layer > New > Solid. The 
Solid Settings dialog box appears (Figure 39).

4. Select a color and click OK to close the Solid Settings 
dialog box.

Figure 39 Solid Settings dialog box

Figure 38 3D Rain Down Words & Colors animation 
preset with 3D axis visible
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5. Double-click the solid layer in the Timeline panel.

The Layer panel appears, with the solid color layer 
displayed in it (Figure 40).

6. In the main menu, select Window > Workspace > 
Paint. The Paint and Brushes panels appear.

7. In the Tools panel, select the Brush tool (Figure 41).

The options in the Paint and Brushes panels become 
active and accessible (Figure 42).

8. In the Brushes panel, select a brush.

You can change the tip diameter, put it at an angle, 
change its roundness (turn it into an oval), alter its 
hardness (more or less diffusion around its perimeter), 
and select and update spacing.

Note: Spacing is the distance between the brush 
marks in a stroke, measured as a percentage of the 
brush diameter. When this option is deselected, the 
speed at which you drag to create the brush stroke 
determines the spacing.

Note: Brush Dynamics determines how brush marks 
are controlled by the features of a pressure-sensitive 
digitizing tablet, such as a Wacom pen tablet.

9. In the Paint panel, select a color and paint a single 
line on the solid layer in the Layer panel.

Figure 40 Layer panel

Figure 41 Tools panel
Brush tool

Figure 42 Paint panel and Brushes panel
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10. Change the color and continue until you’ve created a 
graphic that has several lines and colors (Figure 43).

11. In the Timeline panel, display the solid color layer 
options, display Effects, and display Paint.

Each stroke appears in its own layer (Figure 44).

12. Drag each brush stroke a different distance to the right 
to create a stair-step effect, so the strokes appear 
on-screen in the order you drew them (from the 
bottom of the list to the top) (Figure 45).

13. In the Timeline, display the Brush 1 Stroke options.

14. Set keyframes for the End option:

• 0% at the beginning of the time ruler

• 100% at about 2 seconds

15. Play the project and view it in the Composition panel.

The first paint stroke animates just as you drew it. You can 
apply the same animation to the remaining strokes by repeating steps 13 and 14 for each of the brush strokes.

Note: To paint on a video clip, drag the clip into the Timeline, double-click to open it in the Layer panel, and paint 
directly on the video clip.

Figure 43 Paint example

Figure 44 Timeline panel brush strokes

Figure 45 Brush strokes timed to appear at different times in the Timeline, with keyframes added
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